Spring Boot ではMaven3を使わないとエラーになる件

spring

最近話題のSpring Bootですが、Mavenのバージョンは3を使わないとどうやらエラーになるようです。

Spring Bootの設定が終わりいざ実行してみたらエラー。設定は間違っていないと思いながらも少しはまってしまいました。

同じ思いをされている人もいると思うので備忘録として残しておきます。

[スポンサーリンク]

今回発生したエラー

Spring Bootをmvn spring-boot:runで実行したところこちらのエラーが発生しました。
Mavenのバージョンが2だったことが原因のよう。Maven3をインストールして再度実行したら正常に動きました。

Error configuring: org.springframework.boot:spring-boot-maven-plugin. Reason: Unable to retrieve component configurator for plugin configur

springとjavaのバージョン

spring-boot-starter-parentのバージョンは、1.2.3を使っています。
javaは、version 8です。

参考にしたサイト

同じようなことが原因ではまっている人もいたようです。

さいごに

Spring Boot最近話題ですがまだまだ文献が少ないですね。とはいっても書籍も徐々にですが増えてきているようですので今後はもう少し楽に開発できそうですね。

新しいテクノロジを使うには周辺の環境も最新にしたほうがよいということでしょうかね。今回のことで教訓になりました。

それでは!